Белый экран на странице админки /manager/

Добрый день!

Вчера неожиданно админка (/manager/) стала открывается белым пустым экраном. При входе через режим инкогнито браузера она открывается нормально, но при залогинивании опять белый экран.

— Ничего не обновлял
— Кэш почистил
— error.log сервера пустой
— access.log сервера — ничего подозрительного
anton
27 января 2016, 07:25
modx.pro
5 462
0

Комментарии: 19

Василий Наумкин
27 января 2016, 10:31
0
Какой-то код выполняется только для авторизованного юзера и делает ошибку 500.
    anton
    27 января 2016, 11:06
    0
    Как-то можно это отследить? Где еще можно логи посмотреть кроме хостинга? пользователь — админ, ничего для него не менял, за несколько часов до белого экрана все работало хорошо
      Максим Кузнецов
      27 января 2016, 11:17
      0
      Ошибка 500 = ошибка на стороне сервера -> смотреть нужно именно логи сервера.
        Сергей Шлоков
        27 января 2016, 11:53
        0
        Можно добавить в manager/index.php в начало
        ini_set('display_errors', 1);
        ini_set('error_reporting', -1);
        и посмотреть что пишет.
        П.С. Потом не забыть удалить.
      Пётр Молчанов
      27 января 2016, 10:46
      0
      Смотри плагины и поищи тут похожие вопросы, там жаловались на какой-то сторонний компонент. И вспоминай свои последние действия до этого момента)
        anton
        27 января 2016, 11:05
        0
        Похожие вопросы смотрел и здесь, а на других форумах и в гугле, ответа не нашел. И важно: ничего не менял перед тем как перестало работать!
          Пётр Молчанов
          27 января 2016, 11:11
          0
          Если есть доступ к БД, то в таблице modx_site_plugins поставь всем disabled=1 (тока запомни у каких стоял 0:)), сбрось кеш (если файловый, то удали содержимое папки /core/cache) и проверь админку
        anton
        28 января 2016, 09:52
        +1
        В общем стало понятно, что проблема в хостинге nic.ru и виджете «Канал безопасности MODX» если его удалить или отключить в системных настройках, то белый экран пропадает
        Алексей Шумаев
        28 января 2016, 13:06
        0
        У меня аналогично — куча сайтов не работают, в логах ничего. Поддержка копипастит факи.
        НО. Некоторые сайты работают на той же площадке, канал безопасности везде есть.

        Мало того, сейчас заметил, что на хостинге перестали работать некоторые функции программы, написанной с использованием XPDO. На локальном сервере всё нормально, вчера программа работала и на хостинге. И то же самое — никаких ошибок.
          anton
          28 января 2016, 13:21
          0
          nic.ru? Переходите по ссылке вида: site.ru/manager/?a=system/settings
          и в настройках ставите «нет», см скрин. clip2net.com/s/3twsnDT
            Igor Ivanov
            28 января 2016, 15:22
            0
            Спасибо! У меня тоже только что такая же проблема вылезла, ваш способ помог. Хорошо, что у вас раньше случилось и вы успели ее решить )
          Алексей Шумаев
          28 января 2016, 13:17
          0
          Мне отключение feed_modx_security_enabled не помогло.
            anton
            28 января 2016, 13:19
            0
            Я отключил feed_modx_news_enabled и feed_modx_security_enabled, все работает. В принципе легко заходит в site.ru/manager/?a=system/settings.
              Алексей Шумаев
              28 января 2016, 13:20
              0
              feed_modx_news_enabled тоже отключил — не помогает (
                anton
                28 января 2016, 13:22
                0
                сюда заходит? site.ru/manager/?a=system/settings
                nic.ru?
                  Алексей Шумаев
                  28 января 2016, 13:33
                  0
                  Антон, спасибо, я затупил.
                  Да, зашёл, вырубил виджет канала безопасности — всё нормально.
                  Теперь бы понять причину…
            Алексей Шумаев
            28 января 2016, 13:20
            0
            не пойму, почему в логах ничего нет
              OS
              OS
              15 июля 2019, 00:21
              0
              У меня белый экран админки каждый раз после обновления исправляется изменением языка админки с русского на английский в базе через phpmyadmin. Так и живем- с английской админкой.
                Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
                19