Сайт на https. Не ставит слэш после url сайта

Перевела сайт на https, теперь некоторые ссылки открываются в виде htts://site.rupage.html, т.е. не ставит слэш.
Я сделала новый параметр base_href со значением /
Также есть параметр site_url со значением sitename.ru (без слэша в конце)
Есть форма регистрации
<form action='[[~[[*id]]]]' method='post' id='ulregister'>
При регистрации переадрессует на страницу site.ruproregistration/spasibo-za-registracziu!.html?username=tester

Если ставлю слэш в конце у параметра site_url, то не работает регистрация: не проверяет поля, остается на той же странице.

Подскажите плиз что можно сделать?
Любовь
13 июля 2016, 05:50
modx.pro
1 205
0

Комментарии: 3

Любовь
13 июля 2016, 13:20
0
Писала даже полностью
action="http://site.ru/[[~[[*id]]]]
Не работает. И на почту в письме о подтверждении регистрации также приходит без слэша.
    Любовь
    14 июля 2016, 07:24
    +1
    Иногда одни и те же действия, выполненный в разное время приводят к разным результатам…
    Так и у меня: поставила в настройках слэш после названия сайта и на этот раз все заработало.
      SEQUEL.ONE
      24 июля 2016, 02:38
      +1
      Между тэгами
      <head>...</head>
      обязательно вставляйте тэг base вот так:

      <base href="[[!++site_url]]" />
      А если возникают проблемы с правильным отображением в настройках контекста создайте новый параметр site_url и в значение впишите URL сайта
      https://site.com/
      с закрывающимся слэшем в конце.
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        3