Небольшая сложность с pdoTools.

Добрый день, ситуация следующая. Есть страница. onko.d.bdcolors.eu/konsultacii/. Почему то например в Firefox все отлично работает, а вот в хроме с концами зависает. Не могу понять в чем моя ошибка. Права на assets выставил на исполнение, но не помогло. При чем ошибка в консолях не выводится ни в одной, ни в другой.

В ней минимум кода:
<!doctype html>
<html class="no-js" lang="">
    <head>
        
    </head>
    <body>
    <div id="pdopage">
        [[!+page.nav]]
        <div class="rows">
            [[!pdoPage?
                &parents=`0`
                &ajaxMode=`button`
                &limit=`5`
                &tpl=`@INLINE <div>[[+pagetitle]]</div>
`
            ]]
        </div>
    </div>
    <script src="/assets/js/vendor/jquery-1.12.0.min.js"></script>
    </body>
<html>
Павел Карелин
08 июля 2016, 16:05
modx.pro
3 081
0

Комментарии: 31

Борис И
08 июля 2016, 20:56
0
Посмотрел в Firefox 47.0.1, опере, хроме, яндекс браузере, IE — у меня не подгружает, висит везде. Глупое предложение, а версию jquery-1.12.0.min.js не пробовали поменять.
Владимир
08 июля 2016, 22:31
+1
"NetworkError: 404 Not Found - http://onko.d.bdcolors.eu/konsultacii/konsultacii/?page=2"
— ошибка таки есть, а должно быть
http://onko.d.bdcolors.eu/konsultacii/?page=2
    Павел Карелин
    08 июля 2016, 22:34
    0
    onko.d.bdcolors.eu/konsultacii/konsultacii/?page=2 — такой страницы вообще нет и она вообще ни как в запросах не учавствует в принципе.

    Проблема скорей всего в том что не создается $_SESSION['pdoPage'], почему то и hash тоже нет и соотвественно нас тороне сервера не проходит проверку и отдается пуста строка в итоге.
      Владимир
      08 июля 2016, 22:35
      +1
      а добавьте в вызов pdoPage &scheme=`full`
        Павел Карелин
        08 июля 2016, 22:41
        0
        А при чем здесь формирование урла?
          Владимир
          08 июля 2016, 22:45
          +1
          Да, пардон, scheme в этом
          "NetworkError: 404 Not Found - http://onko.d.bdcolors.eu/konsultacii/konsultacii/?page=2"
          не участвует.
            Павел Карелин
            08 июля 2016, 22:47
            0
            Это если честно вообще какая то левая страница, от куда ты её взял? onko.d.bdcolors.eu/konsultacii/
                Павел Карелин
                08 июля 2016, 22:55
                +1
                Бля, ты прав, прикинь. Спасибо тебе дружище, pdotools просто походу не может определить урл для подгрузки страницы.
                  Павел Карелин
                  08 июля 2016, 22:59
                  0
                  Нет увы дело не в этом, теперь урл должен быть верен, но все равно почему то не работает.((
                    Владимир
                    08 июля 2016, 23:01
                    +1
                    вот на тестовом закинул все тоже в пустой шаблон s5927.h5.modhost.pro/ -работает
                      Павел Карелин
                      08 июля 2016, 23:04
                      0
                      Может действительно это какая то проблема с настройками хостинга, я просто первый раз такое встречаю. Всегда работало на ура.
                      Владимир
                      08 июля 2016, 23:05
                      +1
                      del
                        Павел Карелин
                        08 июля 2016, 23:08
                        0
                        Действительно, скопировал код 1 в 1, не работает.
                          Владимир
                          08 июля 2016, 23:10
                          +1
                          странно однако
                          Владимир
                          08 июля 2016, 23:11
                          0
                          но той ошибки теперь нет, в консоли пусто
                          Павел Карелин
                          08 июля 2016, 23:12
                          0
                          В консоли пусто потому что я поставил базовый урл и от него скачет, я практически уверен что проблема в различии хостеров.
                          Павел Карелин
                          08 июля 2016, 23:51
                          0
                          Ну все правильно он же у меня в контексте находится, думаешь может быть из-за этого?
                          Павел Карелин
                          08 июля 2016, 23:54
                          +1
                          Слушай, реально проблема из-за мультиязычности.
                          Павел Карелин
                          08 июля 2016, 23:55
                          +1
                          onko.d.bdcolors.eu/konsultacii/
                          Отключил настройки контекстов
                          Владимир
                          08 июля 2016, 23:56
                          +1
                          и все заработало)
                          Павел Карелин
                          09 июля 2016, 00:01
                          0
                          Да только осталось понять как подключить контекст)))
                          Владимир
                          09 июля 2016, 00:04
                          +1
                          если на странице
                          http://onko.d.bdcolors.eu/ru/konsultacii/
                          то проблем явно не будет, или в другом контексте и надо вытащить документы из контекста RU?
                          Владимир
                          09 июля 2016, 00:07
                          +1
                          Было: на
                          http://onko.d.bdcolors.eu/konsultacii/
                          запрашивалась
                          http://onko.d.bdcolors.eu/ru/konsultacii/?page=2"
                          Павел Карелин
                          09 июля 2016, 00:09
                          0
                          ну все правильно протому что ru это русский контекст, видимо что то я намудрил с настройками переключения контекста.
                          Павел Карелин
                          09 июля 2016, 00:14
                          0
                          Короче на самом деле нужно было всего лишь слать запросы по основному урлу, без учета контекстов. Блин дружище я даже не знаю как тебя отблагодарить, памятник тебе не рукотвоный!
                          Все работает, но я если честно так и не понял почему в фарике работало, а хроме нет.
                          Владимир
                          09 июля 2016, 00:16
                          0
                          Ты просто недоглядел) :)
                          Владимир
                          09 июля 2016, 00:17
                          0
                          у меня ни где не работало, кстати
          Владимир
          08 июля 2016, 22:36
          0
          такой страницы вообще нет
          да, но в консоли именно такая ошибка
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        31