SimpleSearch - отсутствие результатов

Здравствуйте, товарищи, кто-нибудь сталкивался с проблемой, что SimpleSearch не находит страницы даже по pagetitle? Часть страниц находит, часть нет. Сначала подумал что он не может найти страницы которые лежат внутри Collections, но создал новую — тоже «нет результатов», вызовы копировал с сайта где все работает, результат тот же.
Modx 2.8.1
SimpleSearch 2.1.2
Вызов формы:
<div id="form-search" class="form-overlay">
	<div class="popup-form">
		<div class="close"></div>
			<div class="form-title">Введите запрос для поиска</div>
			[[!SimpleSearchForm? &landing=`232` &tpl=`search.tpl`]] 
	</div>
</div>
Чанк формы:
<form class="sisea-search-form" role="search" id="searchform" action="[[~[[+landing:default=`[[*id]]`]]]]" method="[[+method:default=`get`]]">
  <fieldset>
    <label for="[[+searchIndex]]"></label>
    <input type="text" name="[[+searchIndex]]" name="[[+searchIndex]]" id="[[+searchIndex]]" placeholder="Искать" value="[[+searchValue]]" autocomplete="off" />
    <input type="hidden" name="id" value="[[+landing:default=[[*id]]]]" />
    <input type="submit" value="Поиск" />
  </fieldset>
</form>
<div id="site-search-results" class="site-search-results"></div>
Страница с результатами (ID 232) пробовал и просто вызов сниппета, и с параметрами, и с явным указанием полей, везде один результат.
[[!SimpleSearch? 
										&includeTVs=`1`
									  &processTVs=`1`
										&hideMenu=`2`
										&depth=`20`
									]]



Arahort
24 января 2022, 14:23
modx.pro
106
0

Комментарии: 0

Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
0