modrestcurlclient.class.php в modx 2.7.3 - что за зверь? Создает миллион ошибок в логе

Скачал с офф сайта modx 2.7.3.
После установки смотрю лог ошибок, а там несколько тысяч
[2020-07-02 10:29:47] (ERROR in xPDO::getService @ /home/site/public_html/core/xpdo/xpdo.class.php : 1234) modRestClient::__construct is deprecated since version 2.3.0. Use the modRest classes instead.
[2020-07-02 10:29:47] (ERROR in modRestCurlClient::__construct @ /home/site/public_html/core/model/modx/rest/modrestcurlclient.class.php : 26) modRestClient::__construct is deprecated since version 2.3.0. Use the modRest classes instead.
Судя по пути, это что то из комплекта самого ядра modx.
Кто то сталкивался?
Как то не хочется начинать разработку на сайте, который сразу после установки завалил меня ошибками.
Александр Мельник
02 июля 2020, 11:18
modx.pro
173
0

Комментарии: 3

Евгений Webinmd
02 июля 2020, 11:48
+1
в системных настройках есть ключ
log_deprecated
вот его надо отключить и предупреждения уйдут
Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
3