ПЕРЕНОС САЙТА С ХОСТИНГА НА ЛОКАЛКУ

Всем привет! ребята ктонибудь помогите, замучался/ —
вот что сделал:

1. на бегете обновил модХ до 2.7.3 версии.
2. очистил кеш (в том числе и ручками очистил с фтп)
3. завершил все сеансы.
4. упаковал папку public_html в архив (прямо на хостинге)
5. скачал. залил на локальный сервер
6.переписал все пути в четырех файлах config.core.php
7.переименовал .htaccess (все три файла)
8.экспорт/импорт базы
9.уз установочных файлов modx взял папку setup и затолкал ее в корень сайта/
и тут начинается ерунда
открываю браузер и пишу localhost:8888/сайт/setup — появляется обычная инструкция по установке модХ, делаю обновление — прохожу все проверки связи с бд, кликаю далее и предлагает войти в админке — жму — появляется такой вид// скриншот1
когда захожу в админку- там вот такой вид — скриншот2


а если пишу в браузере localhost:8888/сайт/ — все отлично работает// пробую с разных браузеров и везде работает//
(КЕШ ВЕЗДЕ СКИНУЛ — ПУТИ ПРОПИСАЛ)
<img src="" />
<img src="" />

не понимаю в чем дело//
shurra
31 марта 2020, 15:36
modx.pro
447
0

Комментарии: 13

shurra
31 марта 2020, 16:33
0
все сделал только что// ща от радости место не нахожу себе// надо пойти покурить, приду расскажу про детали на которые надо обращать внимание
    Александр Мельник
    31 марта 2020, 17:47
    0
    Ждем ждем. Ваша энергия и эмоциональность даже заставила улыбнуться)
      shurra
      31 марта 2020, 18:14
      0
      я пока чайник в этих делах. поэтому радости полные штаны :) оказалось все дело в путях// в файле core/config/config.core.php надо было прописать абсолютно каждую мелочь (о чем не говорят ни на одном форуме) на картинке указал какие именно// как только все прописал перезагрузил и модекс вдруг ожил// правда не без грехов — сейчас воюю с страничкой основной в админке слева выводится дерево ресурсов а в центральной части пустота// и почемуто не все компоненты подключились// ищу возможные варианты//

      <img src="" />

      запустил скрипт в корень сайта (для проверки конфиг — нашел вот тут — merinovkv.ru/blog/modx/perenos-modx-revolution-na-xosting/) и скрипт выводит вот такую надпись —
      <img src="" />
        shurra
        31 марта 2020, 18:20
        0
        картинки наоборот загрузил )) может подскажете по админке? вот так выглядит пока (но все работает — например -БЫСТРО ОБНОВИТЬ…
        <img src="" />
        кроме Каталога, все ресурсы отображаются в админке// а каталог и его содержимое нет// (в консоли показывает кучу ошибок с компонентами minishop и тд// )
        еще вот какой нюанс — все пакеты ставил на модкс 2.6.5// потом апгрейдил модекс и переносил сайт// может просто снести компоненты и по новой залить?
      Александр Мельник
      31 марта 2020, 19:04
      0
      не совсем понимаю, что там у вас происходит.
      — зачем обновив сайт который на бегете, вы после переноса его на локальный компьютер снова запустили setup?
      — да скорее всего вы запутались в путях
      — очистили ли вы папку core/cache?
      — у вас хорошо настроенный локальный сервер? странно что вебсервер работает на порту 8888. Это не стандартный порт. Я обычно использую его или 8080 если запускаю встроенный в интерпретатор php сервер.
      — зачем вы переименовывали htaccess что было с ними не так?

      я бы советовал вам создавать локально доменные имена для своих сайтов, а не просто располагать их в директориях, это должно упростить работу и настройку.
        shurra
        31 марта 2020, 19:15
        0
        на бегете я зарегистрирован на бесплатном домене// и пару дней назад они наложили ограничения на домен(изза превышения пост-запросов и перегруз на сервер)// я труханул, и решил быстро все скинуть на локальный// чтоб доделать спокойно на локальном//
        папку кеш до сих пор чищу вручную//
        порт 8888 это сам MAMP предложил// htaccess закинул новые которые шли в комплекте с modx// при переименовании эти файлы становятся скрытые по умолчанию(на mac os) старые файлы тоже работали вроде, но решил перестраховаться// в файлах раскоментил друж урлы// (самое интересное — уже на установленном модХ на локалке любой включенный параметр друж урл — приводит к сбою работы сайта// ) поэтому в настройках выкл/ а в htaccess раскоментил//
        сейчас в консоли вот такое выскакивает — пытаюсь понять что это такое// минишоп переустановил и тинимсе тоже// но не помогает
        <img src="" />
          shurra
          31 марта 2020, 19:30
          0
          я неумею пока создавать доменные имена локально// если подскажете как это делать — буду очень признателен :)
            Александр Мельник
            31 марта 2020, 19:55
            0
            я не знаком с mamp как с программой. Думаю прямо в ней должны быть для этого инструменты.
            Но в любом случае гугл подскажет куда больше чем я.
            и не переживайте, даже если хостинг блокирует сайт за превышение лимитов нагрузки, они не удалят ничего.
          Артем
          31 марта 2020, 22:09
          +1
          надо было прописать абсолютно каждую мелочь (о чем не говорят ни на одном форуме)
          абсолютно ни на одном форуме
            shurra
            31 марта 2020, 23:25
            0
            уважаемый, на картинке я ведь указал о чем именно умалчивают на форумах// скорее всего этому не придают значения// а когда человек не знает и переносит в первый раз (как в моем случае) это становится реальной проблемой/ я не претендую на уникальность, у меня получилось сделать после 5 неудачных попыток/ а вам, вместо таких коментов я бы рекомендовал лучше по делу что нибудь сказать- посоветовать как исправить указанные выше ошибки// в любом случае буду признателен за любую непосильную помощь тут//
              Aborrol
              01 апреля 2020, 00:27
              0
              Да проблема в неверно настроенном mamp, тогда бы по любой из этих инструкций все бы получилось.
              Если совсем все плохо, подними голый modx, и посмотри получившийся конфиг
                shurra
                01 апреля 2020, 00:58
                0
                я именно так и делал))// у меня как пример был голый модХ установлен на локалке, и я паралельно открыл два файла конфига и так переписывал пути//ейчас еще раз прошел по конфигам, смотрю в мампе в конфигах указан 8880 порт/ а в модХ в конфигах прописан 80// добавил две 88 и все заработало ))
            shurra
            01 апреля 2020, 00:58
            0
            ВСЕМ СПАСИБО! НАДЕЮСЬ БУДЕТ РАБОТАТЬ ))
              Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
              13