Ошибка при установке minishop2

Добрый день.
Нам моем сервере для разработки находятся файлы большого количества сайтов, которые созданы на modx и используют minishop2.
Никогда проблем с установкой последнего не возникало, но вот уже второй день при установке пакета minishop2 (скачиваемого с modstore.pro) я получаю ошибку о невозможности создать одну из таблиц.

И в целом minishop работает, но невозможно создать ни одну опцию (что и логично ибо таблицы нет).
Версия mysql 5,6 на сервере.
Ну и собственно вопрос. Minishop недавно обновился и у него изменились требования? Иначе как пояснить тот факт, что до этого я не одну сотню раз его устанавливал без проблем.
Ну и собственно самый важный вопрос — а что делать то?
Спасибо.
Александр Мельник
25 февраля 2020, 18:07
modx.pro
311
0

Комментарии: 6

Станислав
25 февраля 2020, 18:32
0
Можно скопировать саму таблицу из другой БД, костыль, но как решение
    Александр Мельник
    25 февраля 2020, 18:47
    0
    Побоялся, что в дальнейшем вылезут еще где-нибудь проблемы.
    Перенес разработку на другой сервер, на котором версия mysql 5,7
    Лучше потеряю сутки работы сейчас, чем когда проект будет готов на 90 процентов вдруг вылезет какой-то косяк.
    Но все равно очень странно, ведь раньше подобных ошибок не возникало на этом же сервере при этих же настройках.
    Александр Мельник
    25 февраля 2020, 19:46
    0
    Кстати еще одна странность.
    Вроде бы Василий все чанки minishop уже давно переписал на fenom.
    Может я какой-то неверный minishop себе установил, но у него чанки выглядят вот так

    посмотрел версию 2,5,0pl
    Евгений Webinmd
    25 февраля 2020, 21:52
    0
    надо кодировку базы выставить в utf8 а у вас скорей всего utf8mb4

    github.com/bezumkin/miniShop2/issues/391
      Александр Мельник
      25 февраля 2020, 22:14
      0
      Проверял. Я несколько раз переустанавливал и следил за кодировкой. Кодировка utf8_general_ci
      Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
      6