Отваливаются стили у дочерних ресурсов

Приветствую знатоков и взываю о помощи! Долго курил интернеты, форумы и проч., ничего не помогает. Может тут помогут?
Тег base присутствует, пути к файлам стилей корректные, все ссылки ведут куда надо
Кирилл
31 июля 2017, 05:29
modx.pro
1 284
-1

Комментарии: 9

Роман Ильин
31 июля 2017, 08:52
+1
А вы пробовали выключить и включить?
    Кирилл
    31 июля 2017, 09:09
    0
    Выключить и включить ЧТО? компьютер? мозги? стили? вы о чем?
      Роман Ильин
      31 июля 2017, 09:13
      +1
      Мне кажется, у вас где-то ошибка! Исправьте её и все будет хорошо! :-)

      Шучу. Потому что пока вы не дадите ссылку на ваш неработающий сайт/код, ответом на вопрос могут быть только шутки.
        Кирилл
        31 июля 2017, 09:17
        0
          Роман Ильин
          31 июля 2017, 09:22
          +2
          Поставьте / перед assets в:

          <link href="assets/test/css/style.css" rel="stylesheet" type="text/css" media="all">
          <link href="assets/test/css/bootstrap.css" rel="stylesheet" type="text/css" media="all">
            Кирилл
            31 июля 2017, 09:27
            0
            О, спасибо большое, добрый человек.
            Но для просвещения не подскажете, почему в других случаях работает без / (для примера olisher.by/m_7_venge_beloe_steklo)
              Роман Ильин
              31 июля 2017, 09:32
              0
              На том сайте работает потому, что у него все ссылки одноуровневые, без вложенности разделов.
                Кирилл
                31 июля 2017, 09:38
                0
                Еще раз большое спасибо! Тема закрыта
                  Дмитрий Суворов
                  31 июля 2017, 12:40
                  +1
                  а еще существует специальная опция: [[++assets_url]], в Вашем случае было бы:
                  [[++assets_url]]test/css/style.css
    Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
    9