Переезд. Часть полей в админке нет, а фронт - есть

Уж и не знал как уложиться с заголовком, буду признателен тому кто меня спасет
Переезд сайта методом установки на новом месте дистриба, переписывания файлов и перезаливкой БД
Всё прошло вполне успешно, немного были проблемы с кодировкой во фронте, не пускало пользователя, но после того, как через phpMyAdmin сбросил пароль, всё получилось и как зашел, гляжу, а кодировка-то во фронте исправилась!
Однако вот какая беда — во фронте всё на месте, а вот в админке в русских контекстах (основной на сайте это английский) пустота! Есть фотки в сквозных полях, есть название ресурса, а в аннотации и контенте — ПУСТОТА!
Смотрю в таблицах — есть текст! А в админке нету… А во фронте есть… И заглавная И полетела, вместо неё сейчас везде "�?". Можно руками поправить, без проблем, да только в ресурсах-то пустота…

Есть конечно нюанс с кодировкой, я по неопытности установил модэкс с кодировкой UTF-8, а база создалась с кодировкой cp1251_general_ci, поэтому у меня весь русский текст в БД кракозябрами((
Текущая инсталяция Модекса также с кодировкой UTF-8 (смотрел в системных настройках, всё так)
Но ведь не может же быть так, что из-за проблемы кодировки не отображается ничего вообще, даже английских html-тегов?!

Куда копать?
Заранее сердечно благодарю!
PS: Для мультиязычности использую Babel с шаманствами в .htaccess

Интуиция подсказывает что не всё чисто вот с этой таблицей:
yadi.sk/i/SgGhOsCo3CinJm
Серый
03 февраля 2017, 19:42
modx.pro
874
0

Комментарии: 5

Михаил Боровов
04 февраля 2017, 01:51
0
Есть подозрение, что некорректно залился дамп БД.
Какая была кодировка на старом сайте? Соответствует ли она тому что есть сейчас на новом?
Пробовал ли запустить заново установку МодХ? После шаманства, могло что-то сломаться.
Чистил ли папку с кэшем?
Как происходил переезд? Есть же стандартные правила.

Просто скриншот на Яндекс.Диске не показывается (((

Много вопросов, так как мало вводных )
    Серый
    04 февраля 2017, 08:38
    0
    Спасибо, Михаил!
    Трогать что-то заново — элементарно боюсь.
    Кодировка на старом сайте была именно такая же нелепая: БД — cp1251_general_ci, при установке Модэкса — UTF-8
    Папку с кэшем чистил
    ВОт скриншот:

    Сейчас выявил еще один симптом, указывающий на то что видимо дело с кодировкой: есть одна страница с непереведенным контентом, так вот он в русской версии норм отображается…
    Буду колдовать с перезаливкой БД…
    Серый
    04 февраля 2017, 08:52
    0
    UPD: Не отображаются только те поля БД, в которых есть заглавная «И»
    Благо страниц не так уж и много, можно и руками, правда, там у БД кодировка 1251, а записи в ней utf-8)))
    Да, знатные грабли я себе разложил на дороге)))
      Серый
      04 февраля 2017, 11:55
      +1
      РАЗРУЛИЛ!
        Михаил Боровов
        04 февраля 2017, 12:45
        0
        Расскажи народу как — может кому еще поможет!
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        5