Проблемы с отрисовкой админки

При сохранении любого содержимого в админке (сохраняю чанк или содержимое ресурса, или системную настройку меняю), последующая загрузка админки заканчивается так, как приведено на картинке (если не видно картинки: отображается только верхнее меню «Содержимое», «Медиа», «Приложения», «Управление»; фон остального экрана — сине-зеленый градиент).

Причем, если в браузере нажать «Просмотреть html-код», то видно, что страница загружена полностью. Повторный refresh страницы исправляет ситуацию: админка полностью видна. Но последующее любое сохранение снова приводит к частичному отображению страницы.

Проблема повторяется и в Chrome, и в IE.
Ставил даже такой эксперимент: в IE сохранял ресурс, а в Chrome делал refresh. Итог: кривая админка.

Версия: MODX Revo 2.5.2.
Проблема была и в 2.5.1.

Наблюдаю проблему и на локале (Денвер, XAMPP), и на хостинге (timeweb).

Пробовал отключать компрессию css и js одновременно и в кэше, и в системных настройках — не помогло.
Отключил все виджеты на главной (в т.ч. и виджет безопасности) — не помогло.
Пробовал вставлять директивы в .htaccess:
php_value suhosin.get.max_value_length 4096
php_value eaccelerator.enable 0
тоже не помогло.

Может, кто сталкивался?
JIM
JIM
13 января 2017, 08:54
modx.pro
985
0

Комментарии: 3

Павел Романов
13 января 2017, 12:47
+1
Если на сайте стоит Polls, то вот.
    JIM
    JIM
    13 января 2017, 13:14
    0
    Спасибо огромное!!!
    Polls у меня нет. Зато нашел аналогичные ошибки во всех своих самописных extras.
    Не понимаю, откуда взялись эти символы. В Notepad++ их не видно.
    Проблема решена.
      Алексей Ерохин
      13 января 2017, 15:24
      +2
      Если мне не изменяет память, то это BOM-метки, в том же Notepad++ моэно пересохранить без них
    Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
    3