Поиск не выдает результатов

Здравствуйте, подскажите, в чем может быть проблема, я установил simplesearch, сделал чанки и т.д. поиск, как бы работает но все время выписывает:
«По вашему запросу ничего не найдено. Попробуйте ввести похожие по смыслу слова, чтобы получить лучший результат.»
Хотя на сайте информация есть, вообще ни 1 слово не находит, сайт сейчас на тестовой версии и я не настраивал все пункты в системе, кто может подсказать в чем проблема?
Владислав
06 ноября 2014, 12:34
modx.pro
2 659
0

Комментарии: 5

Наумов Алексей
06 ноября 2014, 15:35
0
Сайт индексировали?
    Владислав
    06 ноября 2014, 15:37
    0
    нет, а как это сделать? Я просто раньше ставил данный поиск на другие сайты и он сразу находил.Правда сайты существовали дольше, чем поиск. И на данный сайт у меня в роботе запрещена индексация, это имеет значение?
      Владислав
      06 ноября 2014, 17:48
      0
      в смысле есть какая то отдельная функция для индексирования? или стандартное от поисковиков?
      Павел Левин
      06 ноября 2014, 19:31
      0
      Судя по найденной инструкции, нет события для индексации от сюда вывод, что он шарится по базе в поисках искомого.

      Если всё сделано верно и версия актуальна для движка, то должно работать. Сам же я юзаю поиск от яндекса =)
        Владислав
        07 ноября 2014, 10:33
        0
        Проблема решилась, изменением чанка поиска, вот так работает)
        <form role="search" id="searchform" action="[[~[[+landing:default=`[[*id]]`]]]]" method="[[+method:default=`get`]]">
            <input type="search" name="[[+searchIndex]]" id="[[+searchIndex]]" placeholder="Искать" value="[[+searchValue]]">
            <input type="hidden" name="id" value="[[+landing:default=[[*id]]]]" />
        </form>
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        5