pdotools, ошибка в логах

Добрый день!
Постоянно в логах ModX'а висит ошибка
"(ERROR @ [...]/core/components/pdotools/model/pdotools/pdofetch.class.php: 325) PHP warning: strpos() expects parameter 1 to be string, array given".

Кто-нибудь знает, в чем причина?

С уважением, Игорь.
Игорь
15 апреля 2014, 15:10
modx.pro
1 590
0

Комментарии: 5

Василий Наумкин
15 апреля 2014, 20:53
0
Кто-нибудь знает, в чем причина?
Текст ошибки содержит причину. Ожидалась строка, а там — массив.

Судя по текущему состоянию класса pdoFetch, тебе нужно обновиться.
    Игорь
    15 апреля 2014, 22:06
    0
    pdotools-1.9.1-pl2 стоит, вроде последний.
    Или pdoFetch нужно как-то отдельно от pdoTools обновлять?
      Василий Наумкин
      16 апреля 2014, 05:41
      0
      Даже здесь справа показывает — текущая версия 1.9.2-pl2 от 04.04.2014.
        Игорь
        16 апреля 2014, 10:14
        0
        Ок, спасибо!
        В админке в Управлении пакетами почему-то не показывает, что для pdoTools доступны обновления, хотя до этого обновления к pdoTools там отображались. Вот и думал, что у меня последняя версия.
    Иван
    22 августа 2016, 18:33
    0
    Добрый день!
    Ошибка в логах и не работает сайт:
    ERROR @ /[[...]]/core/components/pdotools/model/pdotools/pdofetch.class.php: 498) PHP warning: array_walk() expects parameter 2 to be a valid callback, no array or string given
      Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
      5