не работает fenom на страницах

Здравствуйте!
Прочитал много инфы в нету по этому поводу и проблему никак неудается решить.
Собственно pdotools_fenom_parser стои ДА, но когда пишу на странице {$id} тогда белая страница
П.С. в шаблоне все работает нормально
Версия МОдкс и ПдоТулс свежие
igor3310
17 июля 2021, 17:47
modx.pro
218
0

Комментарии: 11

Баха Волков
17 июля 2021, 21:31
0
Было бы идеально, если бы вы приложили логи MODX и сервера, предположу, что у вас на странице есть js код и решение миллион раз уже было озвучено на форуме, воспользуйтесь поиском
    igor3310
    18 июля 2021, 12:38
    0
    В логах такое
    [2021-07-18 12:39:29] (ERROR @ D:\SERVER2\OSPanel\domains\modx-revo\core\components\pdotools\model\pdotools\pdotools.class.php: 989) Unexpected token '&' in expression in 4d6a5f09a8d7aeee5589e254fc9c6e75 line 61, near '{$_modx-&' < — there
    скобочек нет в шаблоне и на странице
    П.С. про это читал много раз
      Баха Волков
      18 июля 2021, 15:45
      0
      Тут так и написано, что у вас в одном из чанков есть ошибка в синтаксисе. Так неправильно писать

      {$_modx-&

      Надо

      {$_modx->

      Изучите синтаксис fenom и php и проверьте все чанки и шаблоны
        igor3310
        18 июля 2021, 15:51
        0
        так и пишу в ресурсе так {$_modx->resource.id}
    igor3310
    20 июля 2021, 14:49
    0
    Что так никто и нескажет в чем проблема?
      Андрей
      20 июля 2021, 15:54
      +1
      Если создать ресурс, с шаблоном blank, и прямо в контенте написать:
      {$_modx->resource.id}

      Будет ошибка?
        igor3310
        20 июля 2021, 15:58
        0
        Если на пустом шаблоне и в ресурсе пишу такое {$_modx->resource.id} — то тоже ощибка (белая страница получается)

        П.С. В шаблоне работает нормально
          Андрей
          20 июля 2021, 16:01
          +1
          П.С. В шаблоне работает нормально
          Так, вот это что значит? Т.е. как это в шаблоне работает, но в то же время в пустом — ошибка. Может имеется ввиду Чанк?
            igor3310
            20 июля 2021, 16:02
            0
            в самом ресурсе неработает (на странице)
              Андрей
              20 июля 2021, 16:06
              0
              Есть возможность прислать доступы в личку (кнопка Написать сообщение в профиле)? Интересно посмотреть в чём дело.
      igor3310
      21 июля 2021, 13:34
      +1
      Спасибо Андрею — помог разобраться — там плагин которй я в мануале в каком то взял мешал работать Феному
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        11