ошибка при обновлении до версии modx revo 2.8.3

у когонибудь было такое?

при обновлении до версии modx revo 2.8.3

появляется ошибка

Parse error: syntax error, unexpected '::' (T_PAAMAYIM_NEKUDOTAYIM), expecting ']'

ошибка проявляется при попытке зайти в

manager/reports/System Ifo

залогинившись в manager под admin

minishop2-2.5.0

pdotools-2.12.10

подскажите как поправить, или нужно ждать обновления новой версии modx revo?

Спасибо заранее
Кирилл
05 июня 2021, 10:57
modx.pro
164
0

Комментарии: 6

Кирилл
05 июня 2021, 11:57
0
на версии modx revo 2.8.2 всё нормально

подожду когда пофиксят и выложат новую версию modx revo
    Андрей
    05 июня 2021, 13:02
    0
    подожду когда пофиксят и выложат новую версию modx revo
    Версию php подними до актуальной, >= 7.3.
      Иван Бочкарев
      05 июня 2021, 16:31
      0
      PR уже исправлено. Странно видеть сайты еще на версии php 5.6
        Александр Мельник
        05 июня 2021, 20:35
        0
        Даже в официальной англоязычной документации написано что php 5.6 поддерживается.
        docs.modx.com/current/en/getting-started/server-requirements
        и даже 5.3
        MODX 2.x requires PHP 5.3.3 or higher,
          Андрей
          06 июня 2021, 11:57
          +2
          Сам движок возможно и поддерживает, только зачем ими пользоваться? Это как минимум небезопасно, уже 7.3 в статусе Security fixes only, и лучше работать на 7.4-8. Плюс большинство дополнений уже требует 7+.
            Александр Мельник
            06 июня 2021, 13:52
            0
            Я ни в коем случае не говорю, что ими нужно пользоваться (хотя честно говорю не понимаю, почему говорят что это небезопасно. Версия 5,6 существовала чуть ни не десятилетие, вообще все что было написано на php за последние года использовало ее и это было нормально и безопасно.) Да это очень отлично, что буквально за пару лет php начал активно выпускать новые версии и развиваться и дорос до 8ки, но почему это делает 5,6 небезопасной?

            Плюс считаю что документация должна отражать точные данные, ведь это как букварь для первоклассника (правда не уверен что сейчас в школах еще есть буквари).

            Ну а в качестве примера, когда просто приходится использовать старые версии php могу привести то с чем сталкиваюсь я часто. Мы берем на обслуживание и доработку сайты, которые когда -то кто то разработал на скорую руку и оставил без поддержки. Такие сайты чаще всего делались супербюджетно и находятся на старых хостингах, где нет выбора версий языка к примеру. И либо заказчик не хочет никуда переезжать или же (буду откровенен) совсем не хочется просто так ради собственного развлечения переносить сайт на другой сервер, исправлять миллион возникший ошибок изза смены версии языка — если все отлично работает сейчас и на версии 5,6.

            Конечно когда начинаешь разработку нового сайта на modx то уже нет смысла выбирать 5,6, тут я с вами совершенно согласен.
      Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
      6