site_url пишет https вместо http

Код (ниже) упрямо выдает на нескольких страницах https вместо http. В чем может быть дело?

<base href="[[++site_url]]">
<base href="https://moisait.ru/">
Помогает «Очистить кэш» — но это же НЕ ДЕЛО!
Игорь
12 марта 2020, 09:41
modx.pro
159
0

Комментарии: 10

Артур
12 марта 2020, 09:50
0
В системных настройках протокол поменял?
    Игорь
    12 марта 2020, 21:57
    0
    Ничего не менял, оставил, как после установки MODX.
    А что требуется поменять? И где? Эта настройка зависит от провайдера?
    Остальные страницы отображаются — как положено, причём используется ОДИН и тот же шаблон!
      Артур
      13 марта 2020, 09:11
      0
      В правом верхнем углу шестерёнка, там пункт системные настройки там и ищите. Ещё можно воспользоваться поиском от Яндекса или Гугла напишите там Modx Revolution переход на на https
        Игорь
        13 марта 2020, 10:33
        0
        Я не хочу (пока) переходить на https! И ничего для этого не делал.
        В свойстве link_tag_scheme поставил 0 — посмотрю что будет дальше.

        Получается, виноват конкретный провайдер в конкретном случае?
        Ранее я такого не наблюдал.
      Игорь
      13 марта 2020, 19:40
      0
      link_tag_scheme поставил 0 — всё равно некоторые страницы выводятся с https…
      Ну вот что заставляет MODx выводить site_url с https????

      <base href="[[++site_url]]">
        Александр Мельник
        13 марта 2020, 19:48
        0
        Мне кажется link_tag_scheme это не о том.
        Посмотрите что у вас в системной настройке server_protocol, хотя при установке modx таб должно быть http и только после установки сертификата нужно прописывать https
          Игорь
          13 марта 2020, 19:55
          0
          В server_protocol прописано http
          Я просто НЕ ПОНИМАЮ, раз в день приходится заходить, чистить кзш. Это же бред какой-то?
          Ладно бы там для страниц использовались разные шаблоны, но используется ОДИН и тот же!
          Для одних страниц — всё нормально, для некоторых — постоянные глюки с этим https (которые мне НЕ НУЖЕН сейчас).

          Похожая проблема вот тут
          https://modx.pro/help/10992

          Хостинг на foxcloud.net
            Aborrol
            13 марта 2020, 21:22
            0
            Попробуй
            Сделать 301 редирект с https на http
            Проверить настройки хостинга, нет ли у него принудительного редиректа, так же посмотреть, нигде ли сайт не прописан с https, внутренние и внешние ссылки, встречал ситуацию где была подобная проблема, в меню были ссылки с https прописанные вручную
            сделать сниппет с $_SERVER['HTTP_HOST'] и вызывать его некэшируемым
              Игорь
              13 марта 2020, 23:01
              0
              Всем спасибо!
              Как я и предполагал, «виноват» хостинг (виноват всё равно я) — по умолчанию на хостинге стоит галочка использовать SSL.
              Галочка-то стоит, но ключей нет.
              Удивительно, как сайт «работал», ведь https получали только избранные страницы (непонятно, по какому признаку)?
              Алексей Смирнов
              13 марта 2020, 23:06
              0
              Еще проверьте .htaccess на отсутствие редиректов с http на HttpS.
              Пробовали ли:
              без S написать ИЛИ:
              Еще проверяйте все с браузера в ИНКОГНИТО режиме. тк сам браузер может кешировать редиректы любые.
              Долго писал. Вы уже и решили проблему. Успехов!
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        10