Не выводит изображения

Всем добрый день!
Есть makivi.wowstudio.pro/ в категории joxi.ru/VrwaKViOz0102X вывожу разделы каталога.

Вызываю
[[pdoResources?
                    	&tpl=`category_tpl`
                    	&limit=`24`
                    	&parents=`4`
                    	&depth=`0`
                    	&includeContent=`1`
	                &includeTVs=`image`
	                &sortby=`menuindex`
                        &sortdir=`ASC`
                    ]]

Чанк category_tpl
<div class="col-md-6 col-sm-6 col-lg-3">
                        <div class="category-box">
                            <a href="[[~[[+id]]]]"></a>
                            <div class="category-box-numbers">30 products</div>
                            <h3 class="category-box-title">[[+pagetitle]]</h3>
                            <img src="[[+tv.img:phpthumbon=`w=400&h=400&far=C`]]" alt="[[+pagetitle]]" />
                        </div>
                    </div>
Картинка есть joxi.ru/p27elWuo6byNr7 но упорно не выводится.
Уже пробовала создать другое TV-поле image и через него выводить, та же история.

Уже полдня потеряла на эту историю, не пойму куда копать. Что не так? Почему не выводятся изображения?

Заранее спасибо за помощь!
Елена Бредова
28 июня 2017, 10:11
modx.pro
1 954
0

Комментарии: 10

Евгений Webinmd
28 июня 2017, 13:23
0
у вас в вызове
&includeTVs=`image`
а в самом коде img? а должно быть image

+ если используете источник файлов, то необходимо включать параметр processTVs
    Елена Бредова
    28 июня 2017, 13:36
    0
    Поставила
    [[pdoResources?
                        	&tpl=`category_tpl`
                        	&limit=`24`
                        	&parents=`4`
                        	&depth=`0`
                        	&includeContent=`1`
    	                    &includeTVs=`img`
    	                    &sortby=`menuindex`
                            &sortdir=`ASC`
                            &processTVs=`1`
                        ]]
    Но не помогло. Более того почему-то слетел вывод картинок в слайдере, хотя они тоже на месте joxi.ru/nAy3anuY5ROOmZ

    т.е. вообще картинки не выводятся. Это видимо какая-то системная ошибка?
      Евгений Webinmd
      28 июня 2017, 13:38
      0
      нет это вы что-то делаете не так
      Попробуйте убрать вызов phpthumb и проверить что выводится без него
        Елена Бредова
        28 июня 2017, 13:42
        0
        Это я понимаю :)
        Но я первый раз вижу подобное.
        Нигде не выводятся изображения.

        В этот раз при установке ставила modstore.pro/packages/sites-themes/siteextra
          Елена Бредова
          28 июня 2017, 13:46
          0
          Пробовала, ставлю
          <div class="col-md-6 col-sm-6 col-lg-3">
                                  <div class="category-box">
                                      <a href="[[~[[+id]]]]"></a>
                                      <div class="category-box-numbers">30 products</div>
                                      <h3 class="category-box-title">[[+pagetitle]]</h3>
                                      <img src="[[+tv.img]]" alt="[[+pagetitle]]" />
                                  </div>
                              </div>
          и получаю joxi.ru/4AkwVyuyGDMWAq
            Andrei D.
            28 июня 2017, 15:18
            0
            можете отправить мне эмейл с временным аккаунтом, только напишите, где и что должно выводиться
              Елена Бредова
              28 июня 2017, 16:36
              0
              Да, могу.

              Перенесла все шаблоны на чистый движок makivi2.wowstudio.pro и картинки выводятся.
              Так что дело не вызовах видимо.
      Елена Бредова
      28 июня 2017, 17:02
      0
      Я нашла в чем загвоздка, в joxi.ru/Grq6Q1sQODZ0mz указала путь к файлам, чтобы лишнее не отображалось — это и приводит к тому, что картинки не отображаются.
        Андрей
        28 июня 2017, 17:30
        0
        В пути / вначале не должно быть
          Сергей
          29 июня 2017, 00:58
          -1
          / в начале пути никак не влияет на путь к картинке, попробуйте на любо1 своей картинке, а вообще согласен с мнением, путь не должен начинаться с /
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        10