pdoResources переход по ссылкам

Пытаюсь вернуться на MODX, второй вечер бъюсь с pdoResources....((

Итак: дерево ресерсов

ГОРОДА(1)
	город1(18)
		ТОВАРЫ(20)
			товар1(21)
				МАГАЗИНЫ(28)
					магазин1(24)
					магазин2(26)
			товар2(26)
				МАГАЗИНЫ
					магазин1
					магазин2

	город2(19)
На главной странице сделана выборка по городам с помощью [[pdoResources?]]
Все хорошо, ссылки формируются и работают (переход по ссылкам отрабатывается)

на главной:
[[pdoResources?
	&parents=`1`
	&depth=`0`
	&showHidden=`1`
	&showUnpublished=`1`
	&tpl=`@INLINE <div ><a href="{{~{{+id}}}}">{{+pagetitle}}</a></div>`
]]

На странице «город1(18)» размещаю выборку по товарам:
[[pdoResources?
	&parents=`20`
	&depth=`0`
	&showHidden=`1`
	&showUnpublished=`1`
	&includeTVs=`price.rub`
	&tpl=`@INLINE
	<div><button href="{{~{{+id}}}}">
    		<span>{{+pagetitle}}</span>
    		<span >{{+tv.price.rub}}</span>
    		</button>
	</div>`
]]
На сайте товары выводятся, но по клику на них ничего не происходит, нет перехода на страницу товара1 или товара2.

В исходном коде ссылки сформированы правильно, по клике открывается исходный код страницы «товар1», «товар2».

Предпологаю, что проблема кроется в неправильном использовании мной pdoResources или в URL`ах…
Помогите, посмотрите что здесь не так не замыленным взглядом...!
dikoobraz.com
19 мая 2017, 08:17
modx.pro
2 684
0

Комментарии: 4

Глеб
19 мая 2017, 11:25
0
Вопрос, если это ссылка на товар, то почему используется button а не
<a href="{{+uri}}">
    Олег
    19 мая 2017, 13:48
    0
    {{~{{+id}}}}
    Работает, если сайт функционирует без friendly url в отличие от
    {{+uri}}
    Но не факт, что в данном случае выставлено по этой причине.
    Насчет кнопки согласен.
      dikoobraz.com
      19 мая 2017, 17:21
      0
      Спасибо! Помогло! Поменял
      <button></button>
      на
      <a></a>
      все заработало…
      dikoobraz.com
      19 мая 2017, 17:17
      0
      Спасибо за ответы.
      Пробывал и {{+uri}} и [[~[[+id]]]] и [[+uri]] ни как не выходит. Голову сломал в чем может быть причина…
      Ведь в исходном коде все ссылки нормально прописываются… Отдельно страница открывается, а со страницы на страницу ну никак и все тут… блин…
      Может есть какое-то ограничение на вложенность? Подключение использования вложенных URL тоже не помогло.
      Ребят! Помогите плз…
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        4