Работа Tickets (подсветка) Новый


Привет!
Прошу простить за возможно тупой вопрос.

Поставил последнюю версию Tickets на последнюю версию modx. При создании комментария или тикета у меня не обрабатывается тег
<code></code>
, не проставляется тег
<blockquote>
.

<code></code>
не превращается в тег pre c классом class=«prettyprint». Ошибок скриптов нет, Jevix установлен и НЕ отключен. В общем-то чистая установка…

Может я чет упустил, как заставить код подсвечиваться нормально… Заранее большое спасибо!

Тому, кто поможет вышлю спасибу)

UPD.:
проверил на трех тестовых площадках с разными версиями движка
s3149.h4.modhost.pro/index.php?id=2
s3151.h4.modhost.pro/index.php?id=2
s3150.h4.modhost.pro/index.php?id=2
тоже самое и там… версия 2.4.2-pl 2.4.0-pl и 2.3.5-pl.

Я тупой или и правда не работает?)
08 октября 2015, 13:41    Андрей Сухомозгий   G+  
0    417 0

Комментарии (8)

  1. Stan Ezersky 08 октября 2015, 15:55 # 0
    Проверьте параметры сниппета Jevix:
    s12.postimg.org/g65uh5p3x/Screenshot_1.png
    1. Андрей Сухомозгий 08 октября 2015, 15:57 # 0
      Да, действительно, с цитатой я проглядел. Но что на счет тега code. Он так и не преобразуется в pre c классом class=«prettyprint»
      1. Stan Ezersky 08 октября 2015, 16:00 # 0
        А это уже к разработчику :)
    2. Василий Наумкин 08 октября 2015, 20:09 # +1
      В установочном скрипте потерялось добавление специальных наборов параметров к Jevix.

      Завтра выпущу исправление.
      1. Василий Наумкин 09 октября 2015, 14:59 # 0
        Можно обновляться — версия 1.6.7-pl.

        Помимо наборов параметров исправил еще и обновление таблиц при апгрейде со старых версий.
        1. Андрей Сухомозгий 09 октября 2015, 15:12 # 0
          обновился… работает вот так: пишу тикет, смотрю предпросмотр — все нормально подсвечивается разными цветами.


          Сохраняю и все в серых тонах…


          Пишу комментарий к статье, где есть код, нажимаю предпросмотр — комментарий и весь код на странице подсвечивается


          А когда публикую комментарий все опять в серых тонах…
          1. Василий Наумкин 09 октября 2015, 15:38 # 0
            Обновись еще раз и почисти кэш браузера — добавил инициализацию PrettyPrint при загрузке страницы.
            1. Андрей Сухомозгий 09 октября 2015, 15:46 # 0
              Похоже, что все работает! Спасибо!)
      Вы должны авторизоваться, чтобы оставлять комментарии.