Война с минишопом


Есть категории с подкатегориями. При добавлении товара в подкатегорию в категории он тоже отображается, Уже часа 3 бьюсь. В какую сторону копать?
10 октября 2012, 22:00    Александр Бехер   G+  
0    240 0

Комментарии (9)

  1. Василий Наумкин 10 октября 2012, 22:08 # 0
    В сторону чтений документации, воин.

    Мне совершенно неохота выпытывать, где выводится, каким сниппетом, или это в админке?
    Вопрос задать не можете понятно — ответа не будет.
    1. Александр Бехер 10 октября 2012, 22:18 # 0
      При добавлении товара он отображается во всех категориях и подкатегориях, как сделать так чтобы он отображался в конкретной? Например: Стройматериалы -> Кирпичи -> товар1 (сейчас отображается во всех категориях)
      вывод товаров в категориях реализован так:
       [[!getPage?
          &element=`msGetResources`
          &tpl=`aCategoryRow`
          &limit=`9`
      	&tplFirst=`aCategoryFirst`
      	&tpl_4=`aCategoryFirst`
      	&tpl_7=`aCategoryFirst`
          &sortbyMS=`price`
          &sortdir=`ASC`
        ]])
      
      1. Василий Наумкин 10 октября 2012, 22:23 # 0
        Вкладочку «Категории» у товара не трогали, случаем?

        Если там у всех категорий стоит «Нет», то попробуйте заменить вызов msGetResources на getResources — проблема остается? Если да — вопрос не в miniShop.

        1. Александр Бехер 10 октября 2012, 22:35 # 0
          Стоит «Нет», поменял с msGetResources на getResources — не помогло. Добавлено 2 товара в Стройматериалы -> Кирпичи, они выводятся во всех категориях, добавил товар 3 в Стройматериалы — он не выводится нигде. Вдобавок получил ошибку апача, что-то перемудрил по-ходу))
          1. Denys Butenko 11 октября 2012, 11:03 # 0
            Шаблоны правильно назначены?
            1. Александр Бехер 11 октября 2012, 11:58 # 0
              Денис, все перепроверил. Кажется верно. Один для категорий, другой для товаров.
        2. Максим Полетаев 12 октября 2012, 18:43 # 0
          В вызов getResources добавьте &depth=`0`
          1. Александр Бехер 13 октября 2012, 19:38 # 0
            &depth=`0` помогло. Максим, большое спасибо.
        3. Denys Butenko 12 октября 2012, 19:55 # 0
          Создайте сайт на modx-test.com и повторите все, как на вашем сайте — проблема осталась в гитхаб открывайте issue, проблема исчезла — сделайте 1 в 1 как на modx-test.com
          Вы должны авторизоваться, чтобы оставлять комментарии.