Не обновляется кэш при создании ресурса


Здравствуйте.

В общем, проблема в следующем. Создаю ресурс, заполняю поля «заголовок», «описание» и «содержимое», ставлю галочку «опубликовать», нажимаю на «сохранить». Ресурс сохраняется, в админке показано, что всё сохранено, псевдоним сгенерировался, ресурс «опубликован» (галочка стоит, цвет соответствующий).

Захожу на сайт, ресурса нету. Захожу на страницу ресурса в админке, нажимаю «посмотреть», открывается белая страница без адреса. Если зайти на страницу ресурса и пересохранить, то ресурс показывается на сайте.

Если после первого сохранения ресурса, сбросить кэш через админку, то ресурс появляется на сайте.

Генерировал алиас с помощью translit, и с помощью yTranslit, и в ручую вбивал (компоненты отключал) — без толку. Но если отключить алиас, но ресурс при добавлении сразу видны. В чём может быть дело? В базе, в таблице site_content различий у нового ресурса с другими ресурсами различий нету.
02 october 2012, 15:06    Sadykh Sadykhov   
0    514 0

Comments (7)

  1. Василий Наумкин 02 october 2012, 15:08 # 0
    На вкладке «Дополнительно» при работе с ресурсами есть галочка «Очищать кэш».

    Надо активировать.
    1. Sadykh Sadykhov 02 october 2012, 15:14 # 0
      Стыдно, как-то всё просто оказалось.

      Это я так понимаю нормальное явление, не баг? Логично было сделать при галочке «опубликовать» обязательную чистку кеша, а не отдельно, или я чего-то не понимаю.
      1. Иван Брежнев 02 october 2012, 15:50 # 0
        Вообще не логично)
        1. Sadykh Sadykhov 02 october 2012, 15:52 # 0
          Сарказм? :)
        2. Valentin Rasulov 02 october 2012, 17:48 # 0
          Система -> Настройка ситемы
          Фильтр по разделу -> Кеширование
          параметр cache_default -> Да
          1. Sadykh Sadykhov 02 october 2012, 17:58 # 0
            По умолчанию так.
            1. Sadykh Sadykhov 02 october 2012, 18:00 # 0
              Кстати, однажды я спрашивал это на сообществе, тогда видимо была та же ошибка, но каким-то другим (не знаю каким) способом исправил проблему. Теперь буду знать, спасибо всем.
      You need to login to create comments.