Ошибка с phpthumb в медиаменджере

Здравствуйте, вопрос не нов, но уже абсолютно не знаю куда копать и что делать.
В медиа-менеджере не выводятся эскизы. во фронтенде все работает, а вот в менджере, в медиа — «битые» картинки. Файлы видит, сами изображения да — но не отображает. Путь создает как
"/connectors/system/phpthumb.php?src=files%2Fimg%2Fblokbaster_big.jpg&w=800&h=0&HTTP_MODAUTH=modxЗНАЧЕНИЕКАКОЕТО&f=jpg&q=80&wctx=mgr&source=1"
При этом в журнале ошибок нет, в isp журнал ошибок пуст. Один раз проскочила ошибка на строке 3314, но скорее всего связано с попыткой просмотреть не image файл. больше ни разу ошибок не было.
Что не помогало:
1. basePath выставлял разные значения — файлы видит, эскизы не создает
2. если стереть все с phpthumbs и переправить на src = files/img/blokbaster_big.jpg — картинка будет
3. картинок много, папок с ними много. Пробовал и права 777 на папку с файлами, и права 777 на /connectors/system/phpthumb.php — ничего. причем все остальное работает
4. Мб проблема с библиотеками php? подключил imagik (был только gd2) — не помогло. остальное все включено, при установки\обновлении через setup (думал конфиги где повреждены, исправит — ошибок не было). php 7 в apache. memory_limit — 256Мб, остальные на 128Мб. включены такие библиотеки как: mbstring, iconv, gd, imagik
5. Различные отключения в .htaccess пробовал — ничего. совершенно не знаю, что делать. MODX Revolution 2.6.1-pl (traditional) последний, стоит только phpthumbof — на сайте он работает без ошибок (кстати, говорят, что он уже устарел, но в репозитории все thumbs 2014 года, может какой посоветуете?)
Мне кажется, что все таки у меня или что-то с настройками vds или же где-то, что-то не так с phpthumbs.
Подскажите, было ли у кого то похожее, что чем лечили? Так же замечу, что сайт на https — это может повлиять?
Станислав
08 февраля 2018, 18:23
modx.pro
2 825
+1

Комментарии: 5

Станислав
09 февраля 2018, 06:56
+1
Проблема решена. После принятия всех этапов отчаяния, депрессии и кружек кофе, принял решение перебирать по винтику каждый пункт бэкэнда. Особенно катализатором выступил тот факт, что если поставить на другом домене чистую установку — все работает, значит сервер работает верно. Как итог, оказалось, что пара пакетов приложения вызывали ошибку — это Gallery и getчто-то. Они работали, но когда я залез в раздел приложения и стал пробовать чуть ли не каждое переустановить — эти два пакета выдали ошибку и заполонили лог о невозможности чтения пакета. Вручную скачав и скопировав в core/package запустил заново переустановить. (правда и тут не без заминок, нужно было еще распаковать и в папке скопировать еще одно, связанное, приложения). После успешного завершения в медиаменджере все заработало. И более того, даже частично админка ускорилась.
Т.к. среди сотни страниц прочтенных мной за три мучительных ночи такого варианта не было, хочется верить, что может кому пригодится!
    ck
    ck
    10 апреля 2018, 12:02
    0
    Так же замечу, что сайт на https — это может повлиять?
    День добрый! У меня ошибка с отображением превьюшек исчезла именно при отключении https. Возможно, кто-то знает, как вылечить?
      ck
      ck
      10 апреля 2018, 12:49
      0
      На часть запросов phpthumb сервер корректно отдаёт 200
      https://site/connectors/system/phpthumb.php?src=480x300-scolios.c17.jpg&w=100&h=80&f=png&q=90&far=1&HTTP_MODAUTH=modx596881da08f833.37253110_595acc87650ffcf2.41881549&wctx=mgr&source=4

      Но большинство запросов падает с ошибкой 508:
      Failed to load resource: the server responded with a status of 508 ()
      joxi.ru/ZrJppdt1pGlb2j
        ck
        ck
        10 апреля 2018, 16:10
        0
        Копаем дальше. Статистика сервера показывает превышение допустимого кол-ва одновременно запущенных процессов (Entry Processes). И данное превышение происходит только по защищённому протоколу. Можно ли это поправить в самом MODX?
      Игорь
      26 сентября 2023, 07:18
      0
      Может кто-то решил проблему отображения MIGX картинок внутри MIGX?
      я пробовал еще так forums.modx.com/thread/79003/migx-this-renderimage-phpthumb-errors#dis-post-435441
      но не помогло.

      использую MIGX внутри MIGX фотографии, tv отдельная, используй источник файлов.
      ltdfoto.ru/image/y1lg9R
      но если нажать на любую то отображается.

      в html migx так
      <div class="x-grid3-cell-inner x-grid3-col-0"><img src="/connectors/system/phpthumb.php?h=80&f=png&src=my-picture-1.jpg&source=1" alt=""></div>
      неужели это баг MIGX который еще никто не исправил?
        Авторизуйтесь или зарегистрируйтесь, чтобы оставлять комментарии.
        5